Programming
Fundamentials
Setting Up Development Environment
UnigineScript
High-Level Systems
C++
C#
UUSL (Unified UNIGINE Shader Language)
File Formats
Rebuilding the Engine and Tools
GUI
Double Precision Coordinates
API
Core Library
Containers
Engine Classes
Node-Related Classes
Rendering-Related Classes
Physics-Related Classes
Bounds-Related Classes
GUI-Related Classes
Controls-Related Classes
Pathfinding-Related Classes
Utility Classes

Layer

A  layer is a zero-sized node that has no visual representation and enables to save all its child nodes into a separate .node file. Layer nodes should be used as containers for editing the other nodes in the world: you can split the world into several logical parts and save each of them in a .node file. It will enable to facilitate collaborative work on one project by eliminating conflicts arising from simultaneous editing of this world by several people.

World Nodes Grouped into Several Layers

Notice
All changes made in child nodes of a layer node will not affect the source .world file.

The contents of a layer depend on the hierarchy structure: to become part of a layer, a node should be assigned to it as a child. In the hierarchy list of the Nodes panel, a layer node is displayed as a usual node that can be transformed, cloned and so on.

Layer nodes are especially convenient when using the VCS, because by merging the project modifications there will be no need to match the conflicted files.

Notice
Using layer nodes won't prevent conflicts if the same layer is simultaneously edited by several people.

Unlike a node reference, a layer node can contain more than 1 node of the same level in the hierarchy.

See also

  • A NodeLayer class to edit layers via UnigineScript

Adding a Layer Node

To add a new layer node via UnigineEditor:

  1. Click Create -> Node -> Layer on the Menu bar.
  2. In the Add Layer file dialog window that opens, specify a name for the .node file into which child nodes of the layer will be saved.
  3. Place the layer node in the world.

    Place a Layer Node

Then you should add the child nodes to the layer node: select the required nodes, hold Alt and drag the nodes inside the layer node:

Adding Dynamic Meshes to the Layer

Editing a Layer Node

Changes made in the child nodes of the layer node are saved on the disk when:

  • Clicking Save on the Layer tab of the Nodes panel.
  • Saving the world via File -> Save World or by pressing Ctrl+S.

In both cases only the .node file will be updated.

Layer Tab

The .node file contains all the child nodes of the layer node. All changes made in child nodes of the layer node will not affect the source .world file.

Notice
The layer node itself is not stored in the .node file.
Last update: 2017-07-03