UnigineScript
The Language
Core Library
Engine Library
Node-Related Classes
GUI-Related Classes
Plugins Library
High-Level Systems
Samples
C++ API
API Reference
Integration Samples
Usage Examples
C++ Plugins
Content Creation
Materials
Unigine Material Library
Tutorials

Plugins for Maya

Before exporting and importing models from Maya, you may need to change the World Up Vector to Z-axis in Maya settings. Otherwise, models will be not oriented correctly, because Unigine has a different orientation of the coordinate system. To change World Up Vector, do the following:

  1. Select Window -> Settings/Preferences -> Preferences on a menu bar.
  2. In Settings category, set Up axis to Z.
You may also export object mesh with proper orientation by enabling the Flip option.

Manual Installation

If Unigine plugins were not installed automatically, do the following:

  1. Copy binary files (*.mll for Windows version and *.so for Linux version) into the Maya/bin/plug-ins directory.
  2. Copy MEL scripts (*.mel) into the Maya/scripts/others directory.
  3. Run Maya.
  4. Choose Window -> Settings/Preferences -> Plug-in manager in the Maya main menu.
  5. Set Loaded and Auto load flags for MeshExport, MeshImport, MeshSkinnedExport, and MeshSkinnedImport plugins.

Export into Mesh

To export static geometry into .mesh file:

  1. Select a model you want to export into Unigine.
  2. Select File -> Export Selection... in the main menu.
  3. Choose Mesh Export in the Files of type drop-down list.
  4. Check Flip option (unless Z axis is already used as a world up vector).

Export into mesh from Maya

Static geometry export (into MESH format)

The following options are available for export into the MESH format:

  • Flip — flip YZ axes and invert Y axis. This option allows to export a mesh with a proper orientation even if World Up Vector is set to Y-axis in Maya settings (instead of Z-axis).
  • Scale — scaling ratio. This value scales the size of a mesh.
  • Digits — required precision of exported values (the number of digits after a decimal point to keep).

Export into Skinned Mesh

To export a skinned mesh together with its animation into .smesh file:

  1. Make sure that Z axis is used as a world up vector.
  2. Select a skinned model you want to export into Unigine.
  3. Select File -> Export Selection... in the main menu.
  4. Choose Mesh Skinned Export in the Files of type drop-down list.

Export into skinned mesh from Maya

Skinned mesh export (into SMESH format)

The following options are available for export into the SMESH format:

  • Scale — scaling ratio. This value scales the size of a skinned mesh.
  • Digits — required precision of exported values (the number of digits after a decimal point to keep).

Import of Mesh and Skinned Mesh

To import a Unigine-native mesh or skinned mesh into Maya:

  1. Select File -> Import in the main menu.
  2. Choose a file in .mesh or .smesh format.
Last update: 2017-07-03